application loader coincé au stade de "Authentification avec l'iTunes Store"

J'étais sur le sharepoint download une application pour iTunes connecter, mais le chargeur de l'application a été bloqué à l'étape de "Authentification avec l'iTunes Store" et en attente pendant près d'une heure.Network est très bien et je n'ai jamais vu cela auparavant.Quelqu'un a rencontré ce genre de problème? quelle est la solution? merci d'avance.

J'ai eu ce problème quand derrière un pare-feu.

Je me suis débrouillé en éditant:

/Applications/Xcode.app/Contents/Applications/Application\ Loader.app/Contents/MacOS/itms/java/lib/net.properties 

Si vous ne trouvez pas net.properties dans le path ci-dessus, essayez, car il est changé maintenant.

 /Applications/Xcode.app/Contents/Applications/Application\ Loader.app/Contents/itms/java/lib/net.properties 

Changez la ligne:

 # https.proxyPort=443 

À:

 https.proxyPort=80 

Cela permet à l'application d'utiliser le port HTTP pour HTTPS. Travaillé immédiatement après cela. J'espère que cela t'aides.

Pour être honnête, ce n'est peut-être pas une réponse mais ça a vraiment marché pour moi.

  1. J'ai lancé Application Loader et j'ai commencé à soumettre. Alors que le sumbitting se passait,
  2. J'ai lancé Organiser et j'ai également sélectionné Dissortingbution over archiver in Xcode et j'ai commencé à download simultanément.

Ils ont travaillé set et la deuxième a terminé la soumission.

Juste mon expérience.

J'ai essayé de nombreuses solutions comme l'utilisation du port 80 pour la connection https mais aucune de la solution n'a fonctionné pour moi.

https.proxyPort = 443

à https.proxyPort = 80

Chaque fois que je fais face à ce problème, je télécharge l'application à partir de deux instances différentes du chargeur d'application et cela fonctionne comme un charme.

J'ai deux versions différentes de chargeur d'application sur ma machine, l'un est venu avec XCode4 et l'autre est venu avec XCode5. Cela fonctionne toujours si je télécharge une application à partir de deux instances simultanément.

entrez la description de l'image ici

J'ai été très frustré par cela – non seulement par le problème lui-même, mais l'incertitude jusqu'à quand j'ai besoin d'attendre pour l'appeler "Il ne sera pas – essayer à nouveau." – À quel point je vais quitter l'application Application Loader, ré-emballer mon file ipa et réessayer. Probablement avec un changement de port au file net.properties. Mais cela n'a pas toujours fonctionné de la même manière que la dernière fois. Donc je l'écris ici, surtout pour mon bien!

J'étais sur le point d'appeler un autre jour jeté quand cela a fonctionné, presque comme un charme:

1) Ouvrez le file. Applications> Xcode> Contenu> Applications> Application Loader> Contenu> MacOS> itms> java> lib – net.properties

2) Changez la ligne:

 # https.proxyPort=<whatever> 

à

  https.proxyPort=80 

Assurez-vous de ne pas décommenter # https.proxyHost= – laissez-le comme indiqué (commenté).

3) Démarrer le chargeur d'application. Suivez les étapes habituelles et commencez à download votre ipa en utilisant la command Envoyer.

4) Si vous avez l'printing de passer "" Authentification avec l'iTunes Store "dans un timeout raisonnable (disons 10 minutes à quel moment ma patience s'est épuisée) – vous avez de la chance.

5) Lancez Xcode Organizer. Sélectionnez votre archive et click le button Dissortingbuer. Il montrera des lignes de progression inclinées pour quelques minutes. Si cela ne s'arrête pas, tuez Xcode et réessayez.

6) Après environ 2 minutes d' inclinaison , la progression du solide bleu apparaîtra, et votre "Flappy Bird" s'envolera …! (le mien n'était ni Flappy ni Bird)

(Gardez l'application Loader en vie, juste pour l'avoir autour, je ne sais pas si c'est utile plus, mais je suis juste superstitieux)

  • Solutions de rechange à part, c'est quelque chose qu'Apple doit corriger avant de sortir iOS 8 ou iPhone 6. Sérieusement. Si ce n'est pas le cas, je ne gaspille pas 100 $ l'année prochaine.

(Ou – ce bug sera-t-il toujours là pour empêcher les clones "Flappy" d'inonder le magasin d'applications, pour toujours?)

Testé avec xCode 5: Dans mon cas, ni l'organisateur ni le chargeur d'application n'ont fonctionné: ils se sont empilés dans "Authentification avec l'iTunes Store".

J'ai résolu l'envoi de l'application par l'application Loader, et quand il est arrivé à la "Authentification avec l'iTunes Store" j'ai ouvert l'organisateur et download l'application: l'application Loader et l'organisateur envoyant l'application en même time.

Il semble que quelque chose se passe dans ma configuration de port de routeur et mon ordinateur ne peut pas recevoir la réponse d'iTunes Store indiquant que l'authentification a réussi. Peut-être que le process est de cette façon:

1- Authentification de request de chargeur d'application.

2- L'authentification du magasin Itunes est terminée mais le chargeur d'application ne reçoit jamais la réponse. [Mais c'est authentifié quand même!]

3- Organizer envoie l'application car elle est déjà authentifiée par le chargeur d'application.

Essayez d'utiliser une autre connection Internet. J'ai le même problème lorsque vous essayez de download l'application via Wi-Fi. Rien ne m'aide, mais quand je désactive le Wi-Fi et que j'essaie de le faire via EDGE sur mon iPhone, tout fonctionne!

J'ai résolu ce problème en démarrant la deuxième instance d'Application Loader en première instance en disant "Authentification avec l'App Store …". Vous pouvez démarrer la deuxième instance d'Application Loader à partir de Terminal en utilisant:

 open -n -a "Application Loader" 

Vous pouvez essayer de application uploader . Hier moi aussi j'ai fait face à ce problème et même le téléchargement de l'application n'a pas fonctionné pour moi alors j'ai essayé ceci:

Pour le download via XCode:

Etape 1: Tout d'abord Validez votre file d'archive en cliquant sur le button de validation de l'organisateur.

Étape 2: Ensuite, téléchargez-le sur l'App Store via Oraganiser. En cliquant sur dissortingbuer puis première option et ainsi de suite.

ça a vraiment marché pour moi

Si la validation est réussie lors du téléchargement via l'organiseur, il doit s'agir d'un problème réseau. Le chargeur d'application utilise certains ports spécifiques, notamment le port 443. Si l'un de ces ports est bloqué par votre fournisseur d'access Internet ou sur votre réseau local, le chargeur d'application peut restr bloqué. Certaines applications bloquent également ces ports. Si vous utilisez Skype, fermez-le. Si ça ne marche pas alors cette solution a finalement fonctionné pour moi. Apportez des modifications dans le file net.properties. Vous pouvez accéder à ce file en accédant au dossier Application via le terminal. Puis déplacez-vous dans Xcode.app avec cd Xcode.app next

Contenu avec cd Contenu suivant

Application Loader.app avec cd Application \ Loader.app next

Sommaire / MaxOS / itms / java / lib

Vous trouvez maintenant net.properties.

Maintenant, écrivez sudo pico net.properties et ajoutez les lignes suivantes dans le file

https.ProxyHost =

https.ProxyPort =

https.ProxyUser =

https.ProxyPassword =

Maintenant, lancez le chargeur d'application pour download votre file ipa et cela fonctionnera comme un charme.

Parfois, c'est le tour du réseau. login à un réseau différent peut résoudre ce problème.

J'ai essayé les deux façons (Xcode / application uploader) à la maison, ni travaillé.

Ensuite, j'ai apporté mon macbook de la maison à la bibliothèque, il a terminé le téléchargement dans les 3 ~ 5 minutes là-bas (via l'application Uploader).

Sommaire / MaxOS / itms / java / lib

Vous trouvez maintenant net.properties. Modifiez cela avec votre éditeur de text favori. Ajouter les lignes ci-dessous

https.ProxyHost =

https.ProxyPort =

https.ProxyUser =

https.ProxyPassword =

Vous avez peut-être des problèmes pour download via l'app store via xcode si vous avez une connection Internet lente, mais en utilisant Application loader, vous pouvez réaliser la soumission.

entrez la description de l'image ici Tout ce que j'ai fait était de dupliquer mon application Loader.app dans / Applications et j'ai exécuté les deux chargeurs d'application en même time.

entrez la description de l'image ici

Utilisation simple cette command dans le terminal cela a fonctionné pour moi:

cd ~
mv .itmstransporter / .old_itmstransporter /
"/Applications/Xcode.app/Contents/Applications/Application Loader.app/Contents/itms/bin/iTMSTransporter"

J'ai fait face à un problème similaire aujourd'hui en téléchargeant .ipa via le chargeur d'application qui a été ouvert directement à partir de Spotlight. Chaque fois qu'il passait toutes les étapes, mais restr coincé à l'authentification. (AL Version 2.9)

Après des dizaines d'essais échoués, j'ai lancé Xcode et ouvert le chargeur d'application à partir de Xcode (AL version 2.8) et répété l'étape précédente. Fait intéressant, il a échoué au premier contrôle étape elle-même! Il a dit qu'il avait un problème avec le certificate .. donc suivi toutes les étapes à nouveau pour get de nouveaux certificates dans itunesconnect et sur mac. (si quelqu'un veut … voici de bonnes instructions avec des photos )

Il s'est authentifié et le file binary a bien été téléchargé.

J'ai essayé beaucoup de choses y compris la suggestion fournie ici. Une fois que je me reconnecte dans "Application Loader" pour redémarrer la livraison. Le package a passé l'étape d'authentification et commence à download. Peut-être que "Application Loader" doit revalider votre authentification, mais ne peut pas le dire fort.

Cela m'est arrivé aujourd'hui. J'ai éteint mon Mac puis essayé le chargeur d'application après quelques heures.

Ça a marché.

Je suppose que c'était un problème à iTunes Connect.

Nous avons essayé beaucoup de choses qui donnent dans ce message et d'autres, mais ça n'a pas marché.

Enfin, nous avons donné le file IPA au client pour le download via Application Loader depuis sa fin. Et ça a marché.

Donc, je suggère fortement que si votre application valide bien et il rest encore frappé dans l'authentification, alors plutôt que d'essayer quelque chose, essayez de le download à partir de réseau totalement différent dans différentes régions géocharts.

Cela vous fera économiser beaucoup de time et de maux de tête.

J'ai eu le même problème. Essayer toutes ces réponses peut parfois fonctionner, mais cela prend généralement beaucoup de time et peut ne pas fonctionner à la fin comme dans mon cas.

J'ai trouvé une solution qui fonctionnera probablement pour tous.

  • Créez votre file .ipa par: Product -> Arcive -> Disribute (Enregistrer pour Enterprise ou …) -> Suivant et enregistrez .ipa sur la cible

  • Xcode -> devise de développement Open -> Application Loader -> Livrer votre application -> Choisissez votre file .ipa

Avec quelques minutes, votre application sera envoyée à iTunes. Bonne chance

  • Charles Proxy (ou tout autre proxy) pourrait avoir cet effet.
  • Consultez et acceptez les nouveaux termes dans le centre des membres.

La solution la meilleure et la plus rapide que j'ai trouvée est de copyr 'Application Loader' du dossier 'Applications' vers le bureau, et d'exécuter simultanément les 'Chargeurs d'application'.

Fonctionne comme charme à chaque fois 🙂

Il n'y a rien de mal avec le server de tous les ports dans mon cas. J'ai 9 Mo de construction. Avec une bonne vitesse interenet, cela prend 5 minutes. Je sens que je suis coincé. Mais après quelques minutes, il a téléchargé avec succès.

Il me manquait l'entité de signature de dissortingbution. J'ai créé et ça a marché.

entrez la description de l'image ici

Après avoir lutté pendant des jours avec ce problème la seule solution de travail pour moi est d'utiliser le chargeur d'application avec seulement le protocole DAV sélectionné.

Application Loader -> Preferences -> Avancé -> Utilisez uniquement DAV.

Le problème est dû aux ressortingctions de mon réseau d'entreprise. DAV utilise https donc ce n'est pas bloqué.

Solution trouvée ici: itunesconnect utilisant un chargeur d'application derrière un pare-feu

Ouvrez le terminal et exécutez ces commands

  • cd ~
  • mv .itmstransporter / .old_itmstransporter /
  • "/Applications/Xcode.app/Contents/Applications/Application Loader.app/Contents/itms/bin/iTMSTransporter" obtenu à partir d'ici

Bonjour les amis, ne vous inquiétez pas à ce sujet, il suffit de désactiver l'option de code bit dans les parameters de construction et faire la construction et le téléchargement.

Pas besoin de faire un travail supplémentaire

Essaye celui-là