Quelles applications de la version iOs sont acceptées dans l'App Store

Mon application est actuellement en version 3.2.3. Quelle version des applications iOS est actuellement acceptée par Apple? Liens?

Ma conjecture serait que Apple assurerait la rétrocompatibilité avec leurs couches d'API. Cela signifie que 4.0 peut exécuter n'importe quelle application vers le bas par le biais de la version 1.0, mais 3.2 ne peut pas exécuter une application à partir de la version 3.6 si le code utilisé n'est pas disponible pour ce système.

Par conséquent, vous devriez être en clair.

Apple n'accepte plus la soumission d'applications compatibles (par déclaration dans le paramètre Cible de deployment) avec un operating system iPhone antérieur / inférieur à la version 3.0. Vous ne pouvez utiliser ssortingctement que des API compatibles 2.0, mais le paramètre Cible de deployment empêchera l'installation de cette application sur un périphérique 2.0.

Tout ce qui est compris entre 3,0 et 4,1 pour iPhone / iOS Deployment Target et 3,2 à 4,1 pour iOS Base SDK semble être la plage actuellement acceptée.

Apple vous oblige à faire un lien avec le SDK iOS 4.0 ou 4.1 pour les applications iPhone et iOS 3.2 SDK pour iPad. Toutefois, vous pouvez toujours cibler des appareils iOS 3.x en définissant la 'cible de deployment iOS' dans la window Infos cible sur une version plus ancienne, 3.0 étant la plus ancienne qui sera acceptée par Apple.

Par exemple, ma société a récemment publié un jeu iPhone qui a été construit avec le SDK iOS 4.1, mais dont la cible de deployment iOS était 3.0. De cette façon, tous les appareils iOS 3.0 peuvent exécuter l'application.